CS, CFR & CTR General Help Thread (Installation, Creation and More)

  • 540 replies
  • 64526 views
*

Offline Gravquian

  • *
  • 1115
  • Herbie Popnecker / The Fat Fury
    • View Profile
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #450 on: September 28, 2015, 07:38 PM »
^ Dutcher...
 
Thank you for the leads and information.
 
Wow, script/code details. That may be above my skill level, but worth trying.

Do you recall IBM "Basic A", and the simple codes used by Commodor (C64)
computers?  Yes, old-tech stuff, and not machine language. From many, many
years ago.  That I could work with... :) , a little. Have near forgotten all I knew
about Binary, and Octal. And never knew Hexidecimal. Fortran, Perl, C+/C++,
and others made me dizzy and were beyond me. So I have not messed with them
in years. Is the (XML) code you displayed a form of C++?
 
Again, Thank you, for your assitance. I will see what I can gain by looking up
the tutorials and sections that you mentioned.
 
.
Cafe.Naver  File  Downloading  Tutorial  ... http://www.shyguysworld.com/Archive/index.php/topic,12722.0.html
 Shameful plugs: Gravquian's Generics & Gravquian's Rug Thread
 
" A novel set, requires more than novice experience! "

*

Offline Weber

  • *
  • 1521
  • It's not over till it's over.
    • View Profile
    • velvetskyemusic.com
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #451 on: October 01, 2015, 05:48 AM »
I haven't needed any help or had problems creating cs for a long time, but here am humbly asking for help.
I've made a lamp and it's quite small and I also made 3 separate LOD versions of the model and applied them correctly in the Importer.  So when placed in game and I start to zoom out, I can see the LOD switching taking place but while zooming, the model will disappear and reappear and then at certain angles, it completely disappears altogether.  The highest LOD is only 32 faces with the lowest version being 8, so I can't see why it still disappears unless I set it up incorrectly which I don't think I've done or it's just simply my fairly old/weak computer not being able to keep up.  Furthermore, I followed Vodhins advice on setting up LOD's as well which should result in the object displaying correctly.


Here's a pic of the Importer settings, and I don't have an in game pic because I'm not quite ready to show what I've been working on.
So if anyone has any idea of how to make small objects not disappear I would greatly appreciate it.



*

Offline Dutcher

  • *
  • 2321
  • So long, and thanks for all the fish!
    • View Profile
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #452 on: October 09, 2015, 02:07 AM »
Sorry for the late reply, didn't notice you responding.
Is the (XML) code you displayed a form of C++?
Honestly, I have no idea. I have the impression that xml and c++ have a wholy different purpose. XML is basically a data language which tells what should be where or what object contain what properties. Opposed to C++ which tells what to do in certain situations. My Texture Switcher for instance uses xml to store the data for the textures
Code: [Select]
<Brown_Bricks Filesource="Dutcher's Walls and Edges [Brown Brick]">
    <Info size="256x256" source="CG-textures" text="Your ordinary wall"/>
    <Color amount="0"/>
    <Image source="Samples/Brown bricks.bmp"/>
  </Brown_Bricks>
Which says that the object Brown_Bricks has certain properties such as a text (Your ordinary wall) and an image source amongst others.

In the aforementioned code, the only thing you are interested in are the parts behind translate, which communicate a time and a location. Also make sure that the bonename used in the xml-file is the same as the bonename you use (or in this case effectpoint).




Weber, the LOD-settings work as follows. If the distance is lower than a certain number, it uses that model. For example, if the distance is lower than 8. It uses the first one, if it is 25, it uses the 3 one. However, if it is 417, there is no lod defined and as such doesn't show it (which is why the normal distance is 4000 . On small objects like cups on a table, it is useful to use a lower LOD as you wouldnt see it anyway. However, on bigger things, (and light can sometimes be that, especially in a large light radius), you will need to render it and thus have the biggest LOD set on, say 2000, or even 4000.
As for the angle appearing/dissapearing. That also has to do with the ingame treatment of objects, I don't know why, but I too noticed that besides distance, the angle and the geometry imposter distance have an influence on it. Generally, a higher LOD makes the object appear from further distances.
« Last Edit: October 09, 2015, 02:09 AM by Dutcher »
Just an empty signature guys. Nothing to see here. Cary on.

*

Offline Weber

  • *
  • 1521
  • It's not over till it's over.
    • View Profile
    • velvetskyemusic.com
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #453 on: October 09, 2015, 04:00 AM »
Weber, the LOD-settings work as follows. If the distance is lower than a certain number, it uses that model. For example, if the distance is lower than 8. It uses the first one, if it is 25, it uses the 3 one. However, if it is 417, there is no lod defined and as such doesn't show it (which is why the normal distance is 4000 . On small objects like cups on a table, it is useful to use a lower LOD as you wouldnt see it anyway. However, on bigger things, (and light can sometimes be that, especially in a large light radius), you will need to render it and thus have the biggest LOD set on, say 2000, or even 4000.
As for the angle appearing/dissapearing. That also has to do with the ingame treatment of objects, I don't know why, but I too noticed that besides distance, the angle and the geometry imposter distance have an influence on it. Generally, a higher LOD makes the object appear from further distances.


See I tried the usual method for lod's originally and I just didn't like the results.  It's a very low poly object to begin with and it has a very small light radius which is why I was even more annoyed with the results.  But when I placed one of Vodhins lights as a test, it did not disappear from any angle and was very visible from a far distance also.  So I don't know what trick he does to keep his lights visible at all times, but I sure wish I knew.  And thanks for replying.

*

Offline Dutcher

  • *
  • 2321
  • So long, and thanks for all the fish!
    • View Profile
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #454 on: October 09, 2015, 12:12 PM »
What didn't you like on the first go? Cause if nothing else, I'll just add a 4000 lod and leave the rest as is. This way it wont dissapear so fast while perserving the 8-16-32 set-up
Just an empty signature guys. Nothing to see here. Cary on.

*

Offline Slalamander

  • *
  • 2388
  • I used to be someone else
    • View Profile
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #455 on: October 11, 2015, 06:12 AM »
So, I tried creating a alpha cover for walls, but they aren't really alpha :P

Anyway, what setting should I use to create working alpha textures? I'm not sure what went wrong, nor where.
Spoiler (hover to show)

*

Offline Weber

  • *
  • 1521
  • It's not over till it's over.
    • View Profile
    • velvetskyemusic.com
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #456 on: October 11, 2015, 07:53 AM »
Well in whatever photo editing program you use, you should create a new image and add that image as a layer and adjust the opacity slider to get the desired results. Then once you're happy save it.

*

Offline Elizabeth

  • *
  • 5124
  • shyguy's World Rocks!
    • View Profile
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #457 on: November 16, 2015, 11:21 AM »
I've been using Sketchup for awhile now, but I've never figured out how to save a component to use in another Sketchup file. I can make a component and it will show up in the component menu for the same file it was created in, but when I open another project and browse components it's not there. Can anyone please show me the proper way to do this? :n00b:

*

Offline Gravquian

  • *
  • 1115
  • Herbie Popnecker / The Fat Fury
    • View Profile
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #458 on: November 16, 2015, 07:52 PM »
Elizabeth,
 
Here is the addy of a vid-tut, that is on YouTube...



Hope it is helpful... :)
Cafe.Naver  File  Downloading  Tutorial  ... http://www.shyguysworld.com/Archive/index.php/topic,12722.0.html
 Shameful plugs: Gravquian's Generics & Gravquian's Rug Thread
 
" A novel set, requires more than novice experience! "

*

Offline Elizabeth

  • *
  • 5124
  • shyguy's World Rocks!
    • View Profile
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #459 on: November 16, 2015, 09:37 PM »
Thank you so much, Gravquian! It worked!  :w00t: I appreciate that so much. buddy. :up: :)

*

Offline Elizabeth

  • *
  • 5124
  • shyguy's World Rocks!
    • View Profile
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #460 on: November 18, 2015, 10:28 PM »
I apologize for the double post, but I have a different question. I would like to make stained glass, but have no idea what type of texture and importer settings to use. Can anybody enlighten me? :)

Edit: I think I figured it out. I used the SIGlass setting in the importer, which in hindsight seems rather obvious. I just had no idea that using that setting would make a solid texture transparent! I thought a special texture was necessary when making glass.
« Last Edit: November 20, 2015, 11:36 AM by Elizabeth »

*

Offline Captain EO

  • *
  • 584
  • We are here to change the World
    • View Profile
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #461 on: December 26, 2015, 06:07 PM »
I just got a new computer, Windows 10. I'm trying to get it set up for RCT3 and I installed the plugins to SketchUp 2016. It loads the ASE Exporter plugin with no issue, the rct3 plugin gives this error message and is not showing up under "Extensions".
Quote
Error Loading File rct3.rb
Error: #<SyntaxError: C:/Users/E4/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/rct3.rb:138: syntax error, unexpected ',', expecting =>
       defaults = {"w", 4.m, "d", 20.cm, "h", 3.m}

                       ^
C:/Users/E4/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/rct3.rb:138: syntax error, unexpected ',', expecting :: or '[' or '.'
       defaults = {"w", 4.m, "d", 20.cm, "h", 3.m}

                                 ^
C:/Users/E4/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/rct3.rb:138: syntax error, unexpected ',', expecting :: or '[' or '.'
       defaults = {"w", 4.m, "d", 20.cm, "h", 3.m}

                                             ^
C:/Users/E4/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/rct3.rb:138: syntax error, unexpected '}', expecting keyword_end
       defaults = {"w", 4.m, "d", 20.cm, "h", 3.m}

                                                  ^
C:/Users/E4/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/rct3.rb:176: syntax error, unexpected ',', expecting =>
       defaults = {"w", 4.m, "w2", 4.m, "d", 20.cm, "h", 3.m}

                       ^
C:/Users/E4/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/rct3.rb:176: syntax error, unexpected ',', expecting :: or '[' or '.'
       defaults = {"w", 4.m, "w2", 4.m, "d", 20.cm, "h", 3.m}

                                  ^
C:/Users/E4/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/rct3.rb:176: syntax error, unexpected ',', expecting :: or '[' or '.'
       defaults = {"w", 4.m, "w2", 4.m, "d", 20.cm, "h", 3.m}

                                            ^
C:/Users/E4/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/rct3.rb:176: syntax error, unexpected ',', expecting :: or '[' or '.'
       defaults = {"w", 4.m, "w2", 4.m, "d", 20.cm, "h", 3.m}

                                                        ^
C:/Users/E4/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/rct3.rb:176: syntax error, unexpected '}', expecting keyword_end
       defaults = {"w", 4.m, "w2", 4.m, "d", 20.cm, "h", 3.m}

                                                             ^>
It is installed correctly, the same place as the ASE Exporter which works fine.

Does anybody know whats up?
Can I just build off of the center axis and not worry about the placement template or is that off?

 I've also noticed an error with the Importer. I created a test object to import and when I click install theme, I get a message saying "Unable to create the folder "TEST" The System can not find the path specified" followed by "Theme Successfully Installed". The scenery does not install though. It is not in Style/Themed. I can't find where it is going anywhere on the computer.

Thanks,

Captain EO

*

Offline Weber

  • *
  • 1521
  • It's not over till it's over.
    • View Profile
    • velvetskyemusic.com
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #462 on: December 27, 2015, 07:25 AM »
I apologize for the double post, but I have a different question. I would like to make stained glass, but have no idea what type of texture and importer settings to use. Can anybody enlighten me? :)

Edit: I think I figured it out. I used the SIGlass setting in the importer, which in hindsight seems rather obvious. I just had no idea that using that setting would make a solid texture transparent! I thought a special texture was necessary when making glass.


Glad you got it working.  And you could go either way with your texture.  For future reference, you could make a semi transparent texture and use SIALpha Reflection or SISpecular Reflection.  You can try them and see which you like best.  Making your own texture will give you more control of how you want it to look, but requires a bit more trial and error.  I usually import several versions and decide which I like best.

*

Offline Elizabeth

  • *
  • 5124
  • shyguy's World Rocks!
    • View Profile
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #463 on: December 27, 2015, 07:50 PM »
Thanks for sharing your expertise, Weber! :up: I'll try out your suggestions and see what I can come up with. :)

*

Offline Captain EO

  • *
  • 584
  • We are here to change the World
    • View Profile
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #464 on: January 09, 2016, 02:38 PM »
I need help with the importer. I am not able to import anything because the specified path can not be found on my new computer. What is the exact path the Importer is set to install to? Or is there a way to change the install path to my desktop and then just manually place the folder into my Style/Themed directory?

I really want to work on some of my sets but I keep getting held up at the Importer. Please help, I've been dealing with this for a couple weeks now. Thanks in advance.

*

Offline Gravquian

  • *
  • 1115
  • Herbie Popnecker / The Fat Fury
    • View Profile
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #465 on: January 09, 2016, 06:18 PM »
" ...help with the importer... "

Hey Cap,
   If you have os 8, 8.1, or 10... those file systems are unknown to me.
I have RCT3P, and os Win7. Here is an example of the Importer's default location with my ComSys.
 
(User Name)/AppData/Local/VirtualStore/ Program Files (x86)/Atari/RollerCoaster Tycoon 3 Platinum/Style/Themed
 
The set should have a folder with-in that Themed folder location. Hope this was helpful.
Good Luck.
Cafe.Naver  File  Downloading  Tutorial  ... http://www.shyguysworld.com/Archive/index.php/topic,12722.0.html
 Shameful plugs: Gravquian's Generics & Gravquian's Rug Thread
 
" A novel set, requires more than novice experience! "

*

Offline Captain EO

  • *
  • 584
  • We are here to change the World
    • View Profile
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #466 on: January 09, 2016, 06:44 PM »

Hey Cap,
   If you have os 8, 8.1, or 10... those file systems are unknown to me.
I have RCT3P, and os Win7. Here is an example of the Importer's default location with my ComSys.
 
(User Name)/AppData/Local/VirtualStore/ Program Files (x86)/Atari/RollerCoaster Tycoon 3 Platinum/Style/Themed
 
The set should have a folder with-in that Themed folder location. Hope this was helpful.
Good Luck.
Thanks yeah that's where it would go when I had 7 and 8. Unfortunately that isn't the case here. It's not installing anywhere. It won't show up in game and, on the system itself, not in the default Program Files or VirtualStore directory. I've reinstalled the Importer a few times, even tried to create a directory with RollerCoaster Tycoon 3 (minus Platinum in the name) in both locations. That didn't work either. A complete system search confirms that it was not created anywhere on the computer. It'll find only the OVLs from my work folder with all my textures, ase, skp files, ect...

I've heard others say they've had no problems with it on Win10 at all and I'm not new to CS creation as I've worked with it for years so I'm positive I'm not doing anything wrong or different than usual.

*

Offline Weber

  • *
  • 1521
  • It's not over till it's over.
    • View Profile
    • velvetskyemusic.com
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #467 on: January 11, 2016, 09:09 AM »
I'm glad I still have Windows 7.

*

Offline AcesCalifornia

  • *
  • 145
  • Ambitious But Lazy
    • View Profile
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #468 on: January 14, 2016, 10:37 AM »
Edit 3: Disregard everything, I've deleted everything and decided it's just too much hassle to try to fix all the issues I am getting.
« Last Edit: January 14, 2016, 03:09 PM by AcesCalifornia »

*

Offline zyned

  • *
  • 229
  • shyguy's World Rocks!
    • View Profile
    • www.zyned.nl
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #469 on: January 17, 2016, 11:19 AM »
Hi,

Who knows a tutorial for creating a ride event with sound?

Thanks,

Zyned

*

Offline StationJimJr

  • *
  • 1053
  • There's always money in the Banana stand!!
    • View Profile
  
   
     
     Please don't PM me requests, I don't wanna be rude but I'll ignore you!

*

Offline zyned

  • *
  • 229
  • shyguy's World Rocks!
    • View Profile
    • www.zyned.nl
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #471 on: January 18, 2016, 01:06 AM »
Thanks StationJimJr! This will definitely help me :D

*

Offline Headoverfeet

  • *
  • 9
  • shyguy's World Rocks!
    • View Profile
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #472 on: January 19, 2016, 04:07 PM »
Hi :) just wondering if someone could please post a picture of what is inside their belgabor file? I only had a subfolder called Invisible doodads than sub folders. I had the invisible path extras and paths working but the stalls and utilities weren't so I have removed all the above until I can sort it out...

Thanking you in advance  :up:

*

Offline Headoverfeet

  • *
  • 9
  • shyguy's World Rocks!
    • View Profile
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #473 on: January 19, 2016, 04:11 PM »
While I am posting a request for help...does anyone know if anyone has figured out how to upload a drawing for the laser writer? That little open file image is taunting me so much  :down:

*

Offline Eletigna

  • *
  • 149
  • shyguy's World Rocks!
    • View Profile
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #474 on: January 19, 2016, 05:10 PM »
No double post, please.  ;)

*

Offline DACS

  • *
  • 90
  • shyguy's World Rocks!
    • View Profile
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #475 on: February 14, 2016, 06:27 AM »
Guys, has anyone yet managed to create a custom flat ride with synchronized sound? I did some trials but never got the sound to start during the right animation cycle....

*

Offline zyned

  • *
  • 229
  • shyguy's World Rocks!
    • View Profile
    • www.zyned.nl
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #476 on: February 25, 2016, 10:53 AM »
^ Sorry, can't help you with that. I am just learning to create a cfr atm.

Does anyone know if there is a maximum amount of meshes (groups) the importer can handle?
I am working on a complex animation, but it will result in a lot of meshes. And if so, what is the maximum?

Thanks!
Zyned

*

Offline StationJimJr

  • *
  • 1053
  • There's always money in the Banana stand!!
    • View Profile
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #477 on: February 26, 2016, 03:00 AM »
^ 32. I don't remember where I read that tho :)
  
   
     
     Please don't PM me requests, I don't wanna be rude but I'll ignore you!

*

Offline zyned

  • *
  • 229
  • shyguy's World Rocks!
    • View Profile
    • www.zyned.nl
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #478 on: February 26, 2016, 03:36 AM »
Well, i am sure it is more then that. I am at 72 meshes right now, and it is still working. Isn't 32 the maximum amount of bones?

Edit:

I found it! This line is in some changelog of the importer:

Quote
[added] Partial workaround for the 31 mesh limit. Meshes with the same settings will be merged
on import.
« Last Edit: February 26, 2016, 10:15 AM by zyned »

*

Offline chrislovescoasters

  • *
  • 19
  • shyguy's World Rocks!
    • View Profile
Re: CS, CFR & CTR General Help Thread (Installation, Creation and More)
« Reply #479 on: February 27, 2016, 11:49 AM »
How do I use trains on a track that isnt its own? For example, I use one of francescoasters inverted ctrs on the inverted track expansion by samplerocker. How do I do that?
« Last Edit: February 28, 2016, 08:38 AM by chrislovescoasters »